SQL Power Business Intelligence Productivity Tools

SQL Power Software Forum

SQL Power Software Forum

  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page  [Register] Register /  [Login] Login 
Cann not open Pentaho Data integration software  XML
Forum Index » Pentaho Technical Support
Author Message

Joined: 2007-09-13 13:09:20
Messages: 36


I have installed Pentaho Data Integration software and tried to launch spoon. I get the following error. 'Could not find the main class. Program will exist!.'

Any ideas?
SQL Power Developer

Joined: 2007-01-08 15:10:32
Messages: 873

Hi Ismail,

Your question doesn't give us much to go on, so we've made some assumptions. Most importantly, we're assuming the message said "Program will exit" and not "Program will exist."

Relevant information we still don't know includes:

1. On what operating system were you attempting to launch spoon?
2. Which version(s) of the Java runtime are present on that system?
3. What steps did you take when you tried to launch spoon?
4. Which version of Pentaho DI did you download?
5. What happens when you use the same procedure to launch the same version of spoon on a different computer? If it works, how does the other computer's configuration differ from yours?

Given that I don't know any of the above information, the best I can do for you is to paste the error message (with the spelling correction) into Google. Here is my best guess at the most helpful resource for this error (but not knowing the details of your problem, it may not be helpful):


If that doesn't help, please post a followup with the answers to questions 1-5 above, and we'll do some more detailed research.

It may also help if you read this document, which is about how to ask answerable technical support questions:


(This links into the middle of the document; the first half isn't directly relevant to the present case).


Joined: 2007-01-05 10:40:58
Messages: 96

I had the same problem, but also solved it, here is how I did:

the cause is the JRE version, for example, if you have Oracle installed on your machine, oracle may change you file search path and put an old JRE(in Oracle folder) at the beginning of the path. you need to make sure the kettle software uses the newest version of JRE on your machine, what you need to do is open the spoon.bat file (or other bat file that you want to run), look for a line like this:
REM set PATH=C:\j2sdk1.4.2_01\bin;.;%PATH%
uncomment it by removing "rem", then replace "C:\j2sdk1.4.2_01\bin" with the real path of the JRE on your machine, something looks like this:
"C:\Program Files\Java\jre1.6.0_03\bin", then try to run it again.

Forum Index » Pentaho Technical Support
Go to:   
Powered by JForum 2.1.8 © JForum Team